Difference between revisions of "Releases"

From openZIM
Jump to: navigation, search
(Source Code / Current Development)
Line 38: Line 38:
 
'''If you are looking for binaries, you might rather be interested in [[ZIM Readers|reader applications]] instead.''' The openZIM libraries and tools are not meant for end-users but for software developers which integrate them into reader applications or export tools.
 
'''If you are looking for binaries, you might rather be interested in [[ZIM Readers|reader applications]] instead.''' The openZIM libraries and tools are not meant for end-users but for software developers which integrate them into reader applications or export tools.
  
Get the source code from [[Subversion]]:
+
=== Get the source code from [[Subversion]] ===
 
<pre>
 
<pre>
 
svn co http://svn.openzim.org/svnroot/trunk zim
 
svn co http://svn.openzim.org/svnroot/trunk zim
Line 45: Line 45:
 
See more detailed information for checking out and updating code on our [[Subversion]] page.
 
See more detailed information for checking out and updating code on our [[Subversion]] page.
  
;Requirements:
+
=== Requirements ====
 
If you compile the software from source you need the following libraries installed:
 
If you compile the software from source you need the following libraries installed:
 
* cxxtools (version 2.0)
 
* cxxtools (version 2.0)

Revision as of 07:22, 10 March 2011

see Roadmap - Report any Bugs

Source Code / Current Development

As openZIM provides platform independant tools and libraries, the easiest way to use it is to check out the code directly from our SVN.

If you are looking for binaries, you might rather be interested in reader applications instead. The openZIM libraries and tools are not meant for end-users but for software developers which integrate them into reader applications or export tools.

Get the source code from Subversion

svn co http://svn.openzim.org/svnroot/trunk zim

See more detailed information for checking out and updating code on our Subversion page.

Requirements =

If you compile the software from source you need the following libraries installed:

  • cxxtools (version 2.0)
  • tntdb (for zimwriter) (release 1.1)
  • tntnet (for zimreader) (release 2.0)
  • libxz-dev
  • autoconf
  • automake
  • libtool